Non-AA font rendering seems available everywhere except for Windows.

  • In MacVim, this is possivle via noantialias.
  • When using GTK2 front-end, the same can be achieved by adding antialias=false to the fontconfig query, e.g.: Courier New:size=12:antialias=false:rgba=rgb.
  • For Motif, Athena and GTK1 front-ends, aliased rendering is the only option.

But how do I request it in the GUI version of Vim on Windows (gui_win32)?


Have you tried

 set gfn=Courier_New:h14:qNONANTIALIASED

Works for me in Win10

enter image description here

  • Thanks! That's actually what I found myself after some searching, and that's exactly what crashes Vim 8.0 on Windows 7. But that's a different problem =)
    – Bass
    Dec 13 '18 at 14:52
  • No crash for me with Win7 though I installed Vim 8 some time ago (8.0.586).
    – B Layer
    Dec 14 '18 at 6:11
  • I found these quality modifiers from the os_win.c vim code (which align to the window font quality options): ANTIALIASED NONANTIALIASED CLEARTYPE PROOF DRAFT
    – DarkStar
    Aug 16 '19 at 22:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.