1

I am not precisely able to reproduce the exact conditions under which this occurs, but sometimes, when I press CTRL+u, I get the errors below. I cannot even exit vim with CTRL+c or suspend. I haven't been able to figure out why this is happening, and would appreciate any help, thank you!

enter image description here

  • 1
    It will be hard to help you: does it append when you press <C-u> in normal mode or in insert mode? Have you tried debugging your vimrc ? Have you tried debugging the mapping? I think this is a mapping calling a function which fails because neither :h CTRL-U nor :h i_CTRL-U should call something involving a timer. – statox Dec 10 '18 at 13:37
  • what plugins are you using? Anything involving a timer? Try to grep for s:timer_id inside your runtime directory. – Christian Brabandt Dec 10 '18 at 13:53
  • @ChristianBrabandt , I am using this, and it does have s:timer_id somewhere in there. – sarpu Dec 10 '18 at 14:23
  • Well, that is a collection of vimrc together with several plugins. A short grep, showed, that at least the plugins comfortable_motion, ale and vim-go make use of a s:timer_id variable. So the question would be when does that happen and what plugin is involved. Try to see if there are updates to those plugins available and open an issue there. – Christian Brabandt Dec 10 '18 at 14:27
  • What Vim version are you using? I guess the problem comes from here. Note, also the corresponding issue here and in the upstream repository here – Christian Brabandt Dec 10 '18 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.