I'm trying to configure VIM with Python support in order to use the You Complete Me pluggin.

This question has been asked before. Unfortunately none of the answers have worked for me. Any suggestions or insights would be great.

I'm running a Google VM Instance, Debian 9.4

My first step was to clone the repo for vim, cd into it, and run this

./configure --enable-python3interp=yes --with-python3-config-dir=/usr/lib/python3.5/config-3.5m-x86_64-linux-gnu

Then run make followed by sudo make install

I've tried setting this configuration 30 different ways and every time it's done installing and I run vim --version I still get -python -python3

I'm aware that you cannot have python and python3, I've tried both of them. So far nothing has worked.

  • some other options I tried: ./configure --enable-python3interp=yes / --with-python3-command=/usr/bin/python3 and countless variations in between. – lando2319 Dec 8 at 23:03

Here is what ended up working for me

./configure --enable-python3interp / --with-python3-command=/usr/bin/python3

Between this link and a suggested answer which has since been deleted, I cleaned and redid it, and it finally worked. Now running vim --version shows +python3.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.