1

I am starting to work with vim in iterm2 on macOS. Whenever I am in insert mode and try to type a backslash, the cursor jumps to the buttom of the Terminal-window and a forward slash appears. I have no problem typing a forward slash..

I have tried to find a solution, but couldn't find anything that would help me so far.

Do you have an idea for a solution? Thank you so much!

  • Before going further are you sure that it doesn't come from your vimrc? (See this question) Have you tried to reproduce the problem with another terminal emulator? – statox Nov 22 '18 at 12:56
  • To try with another terminal was very helpful. The standard macOS Terminal worked fine - so I checked the iterm settings and removed the backslash under General -> Characters considered part of word for selection Now I can type a backslash without any problems.. – deltavisions Nov 22 '18 at 16:10
  • I'm glad you fixed your problem. I'm closing this question as off topic because the problem came from the terminal and not vim itself. – statox Nov 22 '18 at 16:31

Browse other questions tagged or ask your own question.