Screenshot of my Vim

As you can see in my case, I can barely see my cursor when it is on an error highlighted by You Complete Me as an error. How do I make my cursor more visible?

My GTK+ theme is Numix, I use Gnome and this is the Gnome Terminal in XTerm colors, if that helps.

New contributor
huB1erTi2 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • what is your background setting? – Christian Brabandt Nov 9 at 11:41
  • Use colors from the background theme, which is Numix, and I don't think that's relevant but I use Arc-Dark as shell theme. – huB1erTi2 Nov 9 at 11:49
  • No, I want to know your background setting. :set background? – Christian Brabandt Nov 9 at 13:34
  • Sorry for being so late @ChristianBrabandt, it's light. background=light – huB1erTi2 Nov 10 at 9:54
  • So try :set background=dark – Christian Brabandt Nov 10 at 18:17
up vote 1 down vote accepted

What fixed my problem, was setting background option to dark, as @ChristianBrabandt suggested in comments on my original post. set background=dark

What it basically does is adjusting the background colors without changing the syntax highlighting colors. I won't go into much detail, as this explains it way better than I ever could.

New contributor
huB1erTi2 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

huB1erTi2 is a new contributor. Be nice, and check out our Code of Conduct.
 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.