4

When I'm using :make, the output doesn't have any color. The text is only white. But when I'm using :!make for a C project or :Cargo run for a rust project ( I also use rust.vim ) , there are colors on the output. ( the colors that the c compiler or the rust compiler have by default)

How can I make the output of make colorful ?

  • Most programs disable text coloring when output is not to a tty (citation needed). If vim could interpret ansi color escapes (provided by some plugins, no experience personally), then you might be able to override with —color flag or similar. – D. Ben Knoble Oct 28 '18 at 23:28
  • That is a bug in cargo – Christian Brabandt Oct 29 '18 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.