0

Neovim from the command line works great in Linux, and I have been using it as a drop in replacement for vim.

However, I am forced to work with windows (7) at my workplace. I am using vim8 which lacks some of my favourite features and also comes out as unreliable with some of the modern plugins.

I have tried to install neovim several times on my windows machine and have never got the qt gui to work. I have tried to install by download and by chocolatey. I have also tried installing on windows 10. Neovim has never worked for me, and I always get a small window with the message that "Neovim is taking too long to respond".

I am just wondering, is it just me who is incompetent or does it betray everyone?

1

I have it installed on my Win10 using scoop. Neovim-qt works better than nvim on cmd but still vim8 is more reliable.

Issue with "Neovim is taking too long to respond" happens when you have smth wrong in your init.vim. Console nvim shows the error and you can continue, neovim-qt on the other hand just hangs.

For example, if I add the messssagae "hello world" as the first line of init.vim I got the behaviour you describe.

I suggest to try run nvim using cmd first, fix the errors that it shows and then try neovim-qt.

I personally like the idea of neovim, but on windows still use vim8 most of the time.

  • Is there a nvim for command line how do you get that to work? Some of the plugin developers are becoming indifferent towards vim8, esp on windows. How do you feel about that? – LazyLeopard Oct 28 '18 at 3:10
  • well, nvim for command line is just nvim.exe. I do install it from scoop and then just nvim on cmd line and it is there. – Maxim Kim Oct 29 '18 at 6:31
  • As for plugin developers that indifferent towards vim8, I don't see it much. There are some, but I don't feel I badly need their plugins. – Maxim Kim Oct 29 '18 at 6:33
  • 1
    As it turns out, it was my incompetence ... partly. I had my vim8 rc file sourced in init.vim and was expecting it to work like it does for nvim in linux. The qt gui reports the error and get stuck like you said, however, the console vim didn't continue unlike what you said, so I thought it was just supposed to start an nvim server or something. That said there are still enough quirks to keep us stuck with no choice but vim 8. – LazyLeopard Oct 31 '18 at 7:28
  • @LazyLeopard, actually you're right, console nvim get stuck for me too. But at least you can see there are errors. – Maxim Kim Oct 31 '18 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.