3

Everytime I open a file vim displays the filename in the command bar, for example I run this:

vim test.test

vim will start with a statusline like this:

"test.test" [New File]                                            0,0-1        All

I'm already using an statusline that displays file name so how can I get rid of it?

5

You can use :set shortmess+=F to prevent Vim from echoing the current filename into the commandline.

See the documentation, e.g. :help 'shortmess'

Note, this might need a recent Vim, since the 'F' flag was always correctly respected. Some recent patches changed that, e.g. 8.1.310 or 8.1.110

1
  • I got this issue in some recent versions, but limited for few type of files like .csv. Nevertheless this fix seams to be working. – Mithun B Jan 18 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.