I want to do wht is asked here:


However, if I follow the answer there, every time I run vim it starts in insert mode and inserts [2;2R

I am using vim8.0 on Ubuntu 18 in the GNOME terminal running the Bash shell.

  • 1
    See vi.stackexchange.com/a/2620/71 Oct 23, 2018 at 12:35
  • @ChristianBrabandt I can't get any of this to work. Do you have a specific solution you'd suggest? The closest I found that actually worked is to redefine <Esc> upon entering insert mode the first time. This would infuriate me. If I end up using <Esc> to enter insert mode, then it'd drive me crazy that it never works the first time
    – Bananach
    Oct 23, 2018 at 13:48
  • I would simply not re-map the escape key. You could try to map it in a VimEnter autocommand, or using a timer, but those are all hacks in my opinion. Oct 23, 2018 at 13:52
  • @ChristianBrabandt I don't mind hacks, I'm new to vim and this would just help me learn. Probably it won't stick with me anyway, but it's frustrating not being able to try. I tried VimEnter unsuccessfully.
    – Bananach
    Oct 23, 2018 at 13:58
  • If you are new to Vim, I suggest going with the default ESC as everybody else ;) Oct 23, 2018 at 14:11


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.