2

I have installed vim-latex v1.10.0 on Fedora 28, using vim-plug:

Plug 'vim-latex/vim-latex'

I've defined an insert mode abbreviation:

:iab bd text

I can trigger bd to expand to "text" only with Tab or CR in a line of the type:

rrrrr bd tttttt

in a tex buffer. Neither Space nor punctuation characters work (but they work in an empty buffer). Why?

2
  • While I'm not sure about it, It's likely a consequence of IMAP plugin that vim-latex uses to define all its insert-mode expansions. The plugin is quite intrusive and have a tendency to neutralize the usual way to define abbreviations and insert-mode mappings. When vim-latex is present, in (La)TeX buffers, it's better to rely on IMAP to define your own expansions, in a ftplugin. – Luc Hermitte Sep 6 '18 at 16:16
  • 2
    Not 100% sure, but think this is the same issue as Wrong abbreviation expansion – Rich Sep 6 '18 at 21:35
0

This is indeed a bug in vim-latex.

I filed Issue #141 at GitHub to report the issue, and prepared PR #142 with a possible fix.


UPDATE: The PR has been accepted upstream, so you might be able to get it fixed by updating your local plug-in, with a command such as:

:PlugUpdate

(And you might need to restart vim afterwards.)

It would be nice if you could confirm this does indeed fix your issue.

6
  • Plug 'filbranden/vim-latex' answered my question. Abbreviations are expanding correctly know. Thank you very much! – Romas Sep 7 '18 at 18:43
  • 1
    Good to know @Romas! Please upvote and mark my answer as correct, as it might help others who are going through the same issues and bump into this page... See "What should I do when someone answers my question?" for more details. Glad your problem is solved now! :-) – filbranden Sep 7 '18 at 21:58
  • BTW, you can go back to the official Plug 'vim-latex/vim-latex', since the change I had was accepted upstream too... (I recommend you do that, since I might not keep that repo around for much longer, and pointing at the official one means you'll get updates later on.) – filbranden Sep 7 '18 at 21:59
  • I confirm that Plug 'vim-latex/vim-latex' also gives the correct expansion of abbreviations now. I am allowed "only post 1 time each day due to the volume of spam and abuse originating from my network" ? I voted for your answers to both my questions, but get a message that "votes of less 15 reputation are recorded but not publicly displayed". I cannot tick your answers because I do not see the "check mark beside the answer" on my screen (tried firefox and chrome). (I could see the green ticks beside answers in other people's questions, but see just background on that spot in my questions.) – user18903 Sep 8 '18 at 20:08
  • only post 1 time each day due to the volume of spam and abuse originating from my network That is because you keep posting "answers" that are not answers @A.Romas, which then have to be deleted :-) You should only use answers for full answers. For everything else, use comments, which is what this is! – Martin Tournoij Sep 9 '18 at 1:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.