0

I installed Vundle via git clone https://github.com/VundleVim/Vundle.vim.git ~/.vim/bundle/Vundle.vim, and have my .vimrc as:

set nocompatible              " be iMproved, required
filetype off                  " required

" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')

" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'



Plugin 'tpope/vim-fugitive'
Plugin 'vim-latex/vim-latex'




set nocompatible              " be iMproved, required
filetype off                  " required

" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')

" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'

When I hit :PluginInstall (!), it shows the plugin screen but only Vundle is installed. Hitting l for the log gives me:

[2018-09-01 22:42:44]                               |
[2018-09-01 22:42:44] Plugin VundleVim/Vundle.vim   |~                                                                                                                                                              
[2018-09-01 22:42:44] $ cd '/home/name/.vim/bundle/|~                                                                                                                                                              
Vundle.vim' && git pull && git submodule update --in|~                                                                                                                                                              
it --recursive                                      |~                                                                                                                                                              
[2018-09-01 22:42:44] > Already up-to-date.         |~                                                                                                                                                              
[2018-09-01 22:42:44] >                             |~                                                                                                                                                              
[2018-09-01 22:42:44]                               |~                                                                                                                                                              
[2018-09-01 22:42:44] Helptags:                     |~                                                                                                                                                              
[2018-09-01 22:42:44] :helptags /home/name/.vim/bun|~                                                                                                                                                              
dle/Vundle.vim/doc                                  |~                                                                                                                                                              
[2018-09-01 22:42:44] Helptags: 1 plugins processed |~                                                                                                                                                              

I've checked the .vimrc path with :echo $MYVIMRC and it points to the above file. I've also tried to install plugins with the command: vim +PluginInstall +qall, and for a millisecond or so it flashes a screen which seems to have a red line, however I can't follow up.

Both curl and git work and are installed. How do I find out where it goes wrong? I've seen similar questions and they are not helpful. I've restarted Vim.

2

In your .vimrc you're calling vundle#begin() twice and after the second one you're only loading the Vundle plugin. That's probably why it's ignoring the other plugins you have outside that block.

You're also missing the call to vundle#end() and re-enabling the filetype detection.

Take a look at Vundle's quick start again to see what your .vimrc should look like.

  • 1
    Thanks! I copy pasted the begining and end of the example .vimrc separately and probably failed to copy the end. What a silly mistake! – ZirconCode Sep 1 '18 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.