I use YouComplete plugin to do language completion but I can't seem to get tags to work for my own files/functions.

I use xolox/vim-misc and xolox/vim-easytags and installed Exhuberant ctags.

my .vimrc setup for easy tags as follows

"Amazing code completion
Plugin 'Valloric/YouCompleteMe'

Plugin 'xolox/vim-misc'
Plugin 'xolox/vim-easytags'

" ----- xolox/vim-easytags settings -----
set tags=~/.vimtags
let g:easytags_events = ['BufReadPost', 'BufWritePost']
let g:easytags_async = 1
let g:easytags_dynamic_files = 2
let g:easytags_resolve_links = 1
let g:easytags_suppress_ctags_warning = 1

What do I have to do to make my custom functions show up in auto complete with YouComplete plugin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.