1

I pulled all the source files, and then ran the following command to configure and tried to build vim with GUI support:

/configure --enable-gui=auto

Here is some more information:

checking --enable-gui argument... yes/auto - automatic GUI support
checking whether or not to look for GTK+ 2... yes
checking --disable-gtktest argument... gtk test enabled
checking for location of Motif GUI includes... <not found>

But the vim I compiled still doesn't support GUI.

vim --version
VIM - Vi IMproved 8.1 (2018 May 18, compiled Jul  6 2018 16:24:24)
Included patches: 1-155
Compiled by coeus@debian9
Huge version without GUI.  Features included (+) or not (-):

I am using Debian Stretch. Can anyone help me?

I tried to follow up with INSTALL file, but it seems it doesn't work, and there are no error messages mentioning the GUI is not compiled... Very strange.

  • 1
    I think there is a Debian package of vim with gui called vim-gtk. I would definitely try it before compiling my own. Edit: In fact, there are several (vim-gnome, vim-athena, etc) – Saul Axel Martinez Ortiz Jul 9 '18 at 2:11
1

I assume that you don't have the needed libraries installed on your system to build a gui. If you read the file src/INSTALL it explains the different --enable-gui options.

For example for me I could run ./configure --enable-gui=kde && make just fine but the resulting vim did not have a gui. When I checked ./configure --enable-gui=kde | grep gui I found that

checking --enable-gui argument... Sorry, kde GUI is not supported

Only when I ran ./configure --enable-gui=gtk2 --with-features=huge && make && src/vim -g it worked properly.

Bottom line: check the output of the configure script and find out if you have the needed libs.

  • I just do this again as your said: $ ./configure --enable-gui=gtk2 | grep -i "g[tu][ki]" checking --enable-gui argument... GTK+ 2.x GUI support checking --disable-gtktest argument... gtk test enabled But when run the make, there is still no GUI support. Which file I should check for details? – Coeus Wang Jul 9 '18 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.