0

I have the following options set to non-default values, as reported by :redir @+ | :set | @redir end:

--- Options ---
autochdir
cscopetag
foldcolumn=7
hlsearch
lazyredraw
relativenumber
sidescroll=1
tabstop=4
undofile
autoindent
cscopeverbose
foldlevel=20
ignorecase
list
ruler
sidescrolloff=10
tildeop
virtualedit=block
autoread
cursorline
foldmethod=indent
incsearch
mouse=a
scroll=25
smartcase
ttimeout
whichwrap=b,s,[,]
background=dark
diffexpr=MyDiff()
foldnestmax=6
langnoremap
mousemodel=popup
scrolloff=10
splitbelow
ttimeoutlen=100
wildmenu
belloff=esc
display=truncate
helplang=en
nolangremap
nrformats=bin,hex
shiftwidth=4
splitright
ttyfast
nowrap
comments=:#
filetype=zsh
history=200
laststatus=2
number
showcmd
syntax=zsh
ttymouse=xterm2
backspace=indent,eol,start
backupdir=~/vim-backup
commentstring=# %s
cscopeprg=/usr/bin/cscope
directory=~/vim-swap
fileencoding=utf-8
fileencodings=ucs-bom,utf-8,latin1
fileformats=unix,dos,mac
formatoptions=croql
guicursor=n-v-c:block,o:hor50,i-ci:hor15,r-cr:hor30,sm:block,a:blinkon0
indentexpr=GetShIndent()
indentkeys=0{,0},!^F,o,O,e,0=then,0=do,0=else,0=elif,0=fi,0=esac,0=done,0=end,),0=;;,0=;&,0=fin,0=fil,0=fip,0=fir,0=fix
listchars=tab:⁞…,trail:·,extends:»,precedes:«,nbsp:¬
statusline=%!airline#statusline(1)
termencoding=utf-8
undodir=~/vim-undo
wildmode=list:longest,full

My runtimepath is

~/.vim,~/.vim/bundle/argtextobj.vim,~/.vim/bundle/CamelCaseMotion,~/.vim/bundle/csv.vim,~/.vim/bundle/perldoc-vim,~/.vim/bundle/promptline.vim,~/.vim/bundle/vim-abolish,~/.vim/bundle/vim-airline,~/.vim/bundle/vim-airline-themes,~/.vim/bundle/vim-better-whitespace,~/.vim/bundle/vim-capslock,~/.vim/bundle/vim-commentary,~/.vim/bundle/vim-expand-region,~/.vim/bundle/vim-fugitive,~/.vim/bundle/vim-lua,~/.vim/bundle/vim-repeat,~/.vim/bundle/vim-rhubarb,~/.vim/bundle/vim-smartword,~/.vim/bundle/vim-speeddating,~/.vim/bundle/vim-surround,~/.vim/bundle/vim-tasks,~/.vim/bundle/vim-textobj-entire,~/.vim/bundle/vim-textobj-indent,~/.vim/bundle/vim-textobj-line,~/.vim/bundle/vim-textobj-user,~/.vim/bundle/vim-tf2,~/.vim/bundle/vim-unimpaired,/usr/share/vim/vimfiles,/usr/share/vim/vim80,/usr/share/vim/vim80/pack/dist/opt/matchit,/usr/share/vim/vimfiles/after,~/.vim/after

(I'm using a lot of plugins)

This problem started after a routine cygwin package update, without me manually changing any configuration files. After much rage, I've found that apparently the scrollwheel only acts funny when my cursor is in a specific screen region on my terminal emulator (which is ConEmu) - everywhere else, it works as normal.

In this region, scrolling gets various numbers, :, <, and >, with no discernable reason for the difference. I leave my emulator and focus a different window, then return, and the "typed" character may or may not be different. Possibly worth noting is that it doesn't force insert mode, it literally acts as if I had pressed the key in question. Definitely worth noting is that this doesn't happen when I'm in the plain command line.

  • First thing first: have you tried debugging your vimrc? Even if the problem is caused by a Cygwin update it might be worth knowing if it still appears without configuration or if it is related to a specific part of your vimrc/plugins – statox Jul 3 '18 at 13:49
1

Try this:

:set nolazyredraw

I was looking at your config and that setting caught my eye. The default is false but you have it enabled. When I enable it in my Cygwin environment and then use the scrollwheel inside a Vim instance launched from within tmux (a terminal emulator) I see behavior quite similar to what you describe (characters unexpectedly inserted into my buffer). Also, I don't see the problem outside of tmux...same as you observe.

Unless you have an explicit reason for setting it all the time you'll probably want to remove that setting from your vimrc. (Some folks enable it only when needed. E.g. to improve response time when running a complicated macro.) Otherwise, you'll at least have to find a way to disable it when you're in ConEmu barring someone producing a way to resolve the underlying issue.

  • I turned off lazy redraw (removed the line from my setting file) and it's no longer doing that. Thank you! – Lilith Jul 4 '18 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.