2

I'm trying to find out how to configure neovim in order to edit texts with accented latin characters. I usually set ambiwidth to double so Jananese symbols are displayed properly, but then neovim treats accented latin characters also as double-width. When, on the other hand, I set ambiwidth to single, the entire text gets completely disfigured, with parts of text not even displayed. Perhaps, I'm missing something?

Incidentally, I happened to notice everything is fine with vim 8.1 when ambiwidth is set to single.

I'm using the latest neovim (v0.3.1-dev) with xfce4-terminal (0.6.3) on an Ubuntu-based system (14.04).

(Solved)

I was not familiar with different sorts of terminals, but the problem resolved itself when I switched xfce4-terminal for rxvt-unicode. Now accented latin characters are displayed properly as single-width when I set ambiwidth to single.

  • 1
    Instead of adding "(Solved)" to the title and answering in question you can answer your questions and mark them as an answer (after 24h). This would be better option. – Hauleth Jul 5 '18 at 20:47
1

At last, I guess I managed to figure out what was really at the bottom of the problem.

Older xfce4-termnal determines how to deal with ambiguous-width characters depending on the value of environment variable VTE_CJK_WIDTH (I usually set VTE_CJK_WIDTH=1), while recent xfce4-terminal has a specific setting that affects ambiguous-width characters. When I set either of these appropriately (i.e. VTE_CJK_WIDTH to 0 or 'ambiguous-width characters' to 'narrow') and also set ambiwidth to single with neovim, then everything goes well and neovim treats accented latin characters as single-width.

As far as I understand, rxvt-unicode cannot properly deal with ambiguous-width characters and always treats these characters as single-width. So this may not be a proper solution to the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.