As you see in the picture, this is the line I mean.


First off, I'm using Neovim. This line only appears when I try to edit python files. Everything is fine with any other language. I think it's because of Syntastic. If I recall correctly, Syntastic sets a maximum length for each line that is 79 characters. This red line delimits the 79th character. When any character exceeds this line, the This line is too long warning appears.

I tried to edit the maximum line length using this command

let g:syntastic_python_pylint_post_args="--max-line-length=200"

I also tried to turn Syntastic off for python files but the line is still there even when Syntastic is not working. This is my init.vim file. It's generated by vim bootstrap but I added some edits to it.

How to get rid of this red line? Thanks in advance

  • 4
    :verbose set colorcolumn? Jun 15, 2018 at 13:45
  • 1
    @ChristianBrabandt it works, Thank you. set cc= . You pointed me to something I didn't know which is colorcolumn. After knowing it I managed to find the line that sets it and I turned it off. Thanks.
    – Moe
    Jun 15, 2018 at 13:57

1 Answer 1


Add this line to your vimrc:

set colorcolumn=0

If you want colorcolumn to remain but with different color, then add

set colorcolumn=81 " or something you want
hi ColorColumn cterm=none gui=none guibg=white ctermfg=white " or whatever you like

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.