1

This question already has an answer here:

I remap Shift + k to noh, but once I installed ale, it is no longer working since one of the command on the package uses the shortcut.

At least as far as I know, I feel that it is related to docstring on Python (likely it outputs the content of the docstring in a file), but even though I searched on the documentation (help ale) using seemingly relevant keywords, I failed to detect which command triggers the shortcut. Reading the documentation all from the top to the bottom is not a solution here (I wish you understand it...).

So is there any way to find which function triggers the shortcut on a third-party library? What I want is prioritize my own custom key remapping over the third-party's.

marked as duplicate by D. Ben Knoble, Herb Wolfe, Hotschke, Christian Brabandt, jamessan Dec 5 '18 at 15:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    type :verbose nmap K and :verbose nmap <buffer> K and see what it says – Mass Jun 11 '18 at 17:58
  • This sounds like a plugin is trying to "extend" the default behavior of K, which I’ve encountered before. Didn’t see any issues with ALE doing so; does this only happen in Python buffers? – D. Ben Knoble Jun 12 '18 at 2:41
  • 2
    You might want to have a read at How do I debug a mapping? – statox Jun 12 '18 at 7:09
  • @Mass K Thanks. The result is *@:call pymode#doc#find()<CR> Last set from ~/.nvim/dein/.cache/init.vim/.dein/ftplugin/python/pymode.vim which appears before my own custom setting. Is there any way to prioritize my own shortcut? (Or should I open a new question?) – Blaszard Jun 16 '18 at 14:06
  • since this is specific to the plugin pymode, you should read the plugin's documentation. In this case it appears let g:pymode_doc=0 or let g:pymode_doc_bind='gK' would work – Mass Jun 16 '18 at 15:17