0

I am trying to set up vim so I can get different functions in with different files (i.e. x.lisp and x.scm) and in the manual it says starting with the option "-u ufile" uses "ufile" as the vimrc

My problem is that the "-u ufile" option does not work as expected. The shortcut for <C-X><C-O> , instead of executing the commands it literally prints out <C-X><C-O>

here is the exact code

 :inoremap <C-h> <C-X><C-O> 

"this works in the .vimrc file but does nothing on the -u ufile.

 :inoremap ^^ <C-X><C-O>   

"this works in the .vimrc file but literally prints out <C-X><C-O> on the -u ufile.

Is there something wrong with the -u option or am I not understanding the manual correctly?

Note: I have managed to do what I want using the "-s sfile" option, (even though it messes up my history somewhat) but to comment i need to use '| # "comment ' otherwise it is read as well for some reason. I am still curious as to why the -u option does not work.

0

if you start vim with -u {vimrc} then vim will not automatically switch off compatibility mode.

You need to have set nocp in your ufile (best as the first line)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.