2

In my system, <C-o> works really slowly compared to <C-i> or <C-p>. Is it just my experience or is there a subtle reason behind it?

Is this in any way related to ttimeoutlen? I saw ttimeoutlen mentionned in a question about slow (user defined) key bindings but I am not sure it is the same problem.

Thank you

6
  • 2
    First you can check the result of :map <C-o> if it returns one (or several lines) with <c-o> followed by other(s) character(s) then setting ttimeout, timeout, ttimeoutlen and timeoutlen differently could be useful for you. In this case you could read this question and you should read the doc :h 'ttimeout' which gives a table describing how to configure these settings. – statox May 15 '18 at 9:08
  • @statox I think it is not mapped. :map lists only two lines: n gx <Plug>NetrwBrowseX n <Plug>NetrwBrowseX * :call netrw#NetrwBrowseX(expand("<cWORD>"),0)<CR> – Cyriac Antony May 15 '18 at 11:25
  • Then the timeout settings shouldn't be a problem here. Have you tried to start vim without a vimrc to check if the problem comes from your configurations? See How do I debug my vimrc? – statox May 15 '18 at 12:23
  • <C-o> is called in normal mode, so :nmap may also apply. Check for that one also. – Vitor May 16 '18 at 13:29
  • @Vitor Actually :map lists the mappings in every mode so :nmap shouldn't show more mappings than :map – statox May 16 '18 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.