1

I'm trying vimtex. Probably I haven't read the docs well enough, but in my system (linux ubuntu 14.04.4 LTS, gvim 7.4) the quickfix list is populated with every single line of the log file when compiling with latexmk, from

This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015/Debian) (preloaded format=pdflatex 2018.1.28)  14 MAY 2018 11:38

to

19 words of extra memory for PDF output out of 10000 (max. 10000000)

How do we configure the parsing of the log file so that only errors and warnings are included in the quickfix list?

  • 2
    This would be what 'errorformat' is for; it is sometimes set by the :compiler command. Can you check the value of that option and the output of the command? – D. Ben Knoble May 14 '18 at 14:08
  • If you are using vimtex, then this should "just work". I'm guessing there is a problem with your .vimrc file or a plugin clash. Feel free to open an issue at vimtex and describe the problem in more detail (please adhere to the issue template). I'm voting to close this question, because it requires much more context for a sufficient answer. – Karl Yngve Lervåg May 15 '18 at 10:57
  • Thanks, Ben. I guess that the errorformat (thank you for that as well, didn't know about it) is set by vimtex, because its different when I open a python or c fie. The :compiler command displays a long lists of options, including tex.vim. Karl, thanks. I do have some latex autocommands on my vimrc with mappings of my own, but I haven't installed any other plugins. I'll look into that. If I can't solve this, I'll open an issue as you suggested. – ljmamoreira May 16 '18 at 9:20
  • Kind of disagree with the "put on hold"... but anyway. – Vitor May 16 '18 at 13:44
  • So, this is related with :help quickfix-valid. Any message that does not match one of the 'errorformat' entries will still be placed in the quickfix window. This is bypassed with the following: set errorformat+=%-G%.%#. Make sure this is done after your compiler was set, because this must be the last entry in 'errorformat'. – Vitor May 16 '18 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.