1

For some reason, Vim started to indent JavaScript in this crazy manner. I bet it's related to some settings in my syntax plugins, but I can't seem to figure out which ones are causing this behavior:

badFormattingWithLongLine.map(m =>
                               ...
                             )

Is there a way to force it to do minimal indentation for all files and filetypes as this Ruby-inspired flag-style is very annoying because I have to dw the whitespace manually for each line.

goodFormattingWithLongLine.map(m =>
  ...
)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.