1

When I get the results of a search (whether via :cw or the Ack.vim plugin), it goes into the quickfix window.

I then open the file by hitting enter, make changes, and save the file.

The quickfix window is now gone.

I'd like to zoom through the files one by one, keeping the quickfix open until I'm done.

It would be best if the quickfix window updates with the last search though I'd rather have it stay open with stale data rather than close and force me to re-run the last search manually.

Any tips?

  • I can't reproduce your problem (with my vimrc and with vim -u NONE): after pressing <CR> to navigate to a file, the qf window doesn't close. Can you try without a vimrc? See this question – statox Apr 20 '18 at 9:48
  • I'll have to try this out when I'm back at that machine... good to know that it's not the default behavior :) Though is there a way to force/override this setting? – davidkomer Apr 20 '18 at 13:03
  • 1
    Well I'm not sure how you disabled this behavior in the first place, maybe an autocmd or something like this. If you don't reproduce the issue without a vimrc, the question I linked in my previous comment should help you to find out what causes the problem. – statox Apr 20 '18 at 13:04
  • 1
    If i remember correctly there is an issue with syntastic which it tries to auto-close/open the quickfix/location window, see Vim: keep location list window open after selecting a file. This may be a related issue or another issue caused by a different plugin. I would suggest enable/disabling plugins to try and find an offending plugin – Peter Rincker Apr 20 '18 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.