0

I have a strange trouble with vim (8.0.95). My format options are fo=cq and nowrap. When I have a long line, which does not fit my terminal window, the view of the file does not include the first column. Lets say the line has 300 characters, but my terminal window only shows 100. Then, if my cursor is on character 300, I can only see characters 201-300.

In this case, when pressing 0, the cursor jumps to character 201, and the horizontal scroll does not change.

If I press Shift+i, the cursor moves to character 1 and switches to insert mode.

The same happens for $ and Shift+a. But it does not happen for a vanilla config. Any idea which plugin/setting might affect this behavior? This happens irrespective of the filetype. And whether I'm in Gnome terminal or on the console.

1

I found the problem. I had some settings for usage of :set wrap lbr with vimtex.

noremap  <buffer> <silent> k gk
noremap  <buffer> <silent> j gj
noremap  <buffer> <silent> 0 g0
noremap  <buffer> <silent> $ g$
onoremap <silent> j gj
onoremap <silent> k gk

I will outsource them to an ftplugin file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.