0

I have this issue with my vim setup, where some words get highlighted unnecessarily. The image below shows an example. The words not and to where highlighted but there's no reason for them to be. How do I stop this from happening?

Additionally, notice this happens with every color scheme I have installed and I'm using the polyglot plugin to provide with syntax highlighting rules for each language.

Thanks

enter image description here

4

It looks like it's highlighting SQL keywords. There is a setting in the PHP syntax highlighter to do that: php_sql_query.

This is off by default, so check your vimrc if you added that, or try adding let g:php_sql_query = 1 to your vimrc.

Also see :help ft-php-syntax.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.