0

I would like to use the mapping

nnoremap <C-k> :bprev<CR>

However, whenever I press ctrl-k, there is a second delay before anything happens. When I use a different key combination, like ctrl-j, everything works fine.

Any idea why this happens and how this can be solved?

  • 1
    You should host your .vimrc somewhere and give a link here so someone can look at the origin of the problem. But of the top of my head I think there is another mapping <C-k> something so that when you press <C-k> it waits and sees if you press another key. Find and disable that keymapping and you should be good to go. – klaus Mar 3 '18 at 17:24
  • Yep, I had a <c-k><c-o> mapping. Thanks for the catch – Chiel ten Brinke Mar 3 '18 at 17:27
  • Leave an answer here, someone might find it useful! – klaus Mar 3 '18 at 17:29
2

There is another mapping Cntrl+k+something so that when you press Cntrl+k, it waits and sees if you press another key. Find and disable that keymapping and you should be good to go.

  • Might be worth mentioning the timeout and timeoutlen settings? – Rich Mar 5 '18 at 15:51
  • i don't know about them, can you do it? – klaus Mar 6 '18 at 7:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.