2

I am using Vim, and somehow the Vim doesn't refresh display properly. enter image description here

For example, I use set cursorline and move to the next time, the remnant of the cursorline remains. Same goes to when I type:, the bottom panel is supposed to be cleared, but the text remained there, which is really annoying. I also tried vim -U NONE -u NONE -N but it didn't solve the problem either. My system is xterm and vim is able to detect the right xterm. I am at a loss as to how to fixed the problem.

I did find a temporary solution, that is type :!clear in Vim, which will keep Vim functional for the session, but it's annoying that I have do this every time I go to vim. Just wondering if there is a better solution.

1

I find the solution. Basically it's an encoding issue. For some reason my Vim doesn't work with UTF-8, so I set my system LANG to ASCII, now everything works just fine. In case anyone runs into similar problem, tinker your encoder setting, which might help.

  • What was your LANG set to before? What's the output of :echo has('multi_byte') in Vim? Also, what is the value of :verbose set encoding with the two different LANG settings? – Rich May 3 '18 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.