2

Not sure how to align the first column with EasyAlign.

Visual select below two lines and ga*space

   wr_strobe <= abc dc asdf  
            rd_strobe <= asd sdfk asdfasd

Only first column is not aligned.

   wr_strobe          <= abc dc   asdf
            rd_strobe <= asd sdfk asdfasd
3

The reason for this is that the default setting of vim-easy-align is to keep the current indentation. You can get the desired alignment with ga<c-i>*<space>.

I find the EasyAlignLign feature to be very useful for this sort of thing. If you map e.g. gA to <plug>(LiveEasyAlign), then visually select your text and do gA. Now you can see how your current settings work. E.g., gA*<space><c-i><space> would give the same result as above, except you would see the changes as you apply the settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.