1

Description

I have a problem with weird unknown symbols in the fileformat placement and encoding sections.

Environment

  • vim: 7.4.1689
  • vim-airline: 0.9
  • OS: Ubuntu 16.04
  • Reproduced with a minimal vimrc: yes
  • vimrc config link
  • Tested on terminals: xfce4-terminal, pantheon-terminal, gnome-terminal, xterm
  • $TERM variable: xterm-256color
  • color configuration (:set t_Co?): t_Co=256
  • am i using Neovim: No
  • does it happen in Vim: Yes

Here is screenshot without let g:airline_powerline_fonts = 1 in .vimrc , i've commented it. image

I want to NOTICE, these symbols are not undisplayed arrow symbols, because i see it in normal, font-enabled mode too image

I have tried to edit let g:airline_section_y (fileencoding, fileformat) from doc/airline.txt by inserting let g:airline_section_y = 'NOT_HERE' into the .vimrc, but it gave me only this image

let g:airline_section_x = 'NOT_HERE' X section - the same nothing image

Same with nerd tree There are no icons for file list at all. You can check my vimrc config link

XTerm

  • For the test, I even deployed vim in docker, latest ubuntu
  • I disabled ALL plugins by PlugClean (vundle), and i still see this symbols
  • Fonts: powerline fonts
  • :echo "\ue0b2" Prints left arrow

Please, tell me how can i remove them? Or what is this?

1

I think it's from the Plug 'ryanoasis/vim-devicons' plugin. You probably need their specific patched fonts along with powerline fonts to work it. Because powerline fonts doesn't cover the huge list of fonts used in the awesome fonts. Personally, I would be way away from these extra burdens just to get some icons in the terminal. So, please remove 'ryanoasis/vim-devicons' plugin and see if the problem goes away. If it does, then you can go ahead and find out how to work the plugin like the way you want to. Let me know what happened, Ok?

  • You are right! Thank you a lot! I have commented this plugin, then :PlugClean, and symbols have disappeared. Then, after re-entering vim, i've installed it again, just to be sure that problem in it, and symbols have appeared again. – det Feb 23 '18 at 23:58
  • Glad I could be of help. If you are satisfied with the answer, please, mark it as accepted. – klaus Feb 24 '18 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.