0

If I open CtrlP in the standard "files" mode I can't find the currently opened file.

I would like to change this behavior: I would like to see all files including the current opened file.

I there a way to change this?

(I couldn't find any such open in the help file)

4
  • How do you open ctrlp in "the standard file mode"? When I do :CtrlP it lists all the files in the directory no matter if they are open in a buffer or not and when I do :CtrlPBuffer it lists only the files open in a buffer.
    – statox
    Commented Feb 8, 2018 at 13:43
  • I just press Ctrl-P. OK, it only filters out the current (active) buffer. Commented Feb 8, 2018 at 13:49
  • Oh then that's just an option to change :) Let me find that again
    – statox
    Commented Feb 8, 2018 at 13:50
  • Updated question accordingly Commented Feb 8, 2018 at 13:52

1 Answer 1

2

From :h 'g:ctrlp_match_current_file':

Includes the current file in the match entries:

let g:ctrlp_match_current_file = 1

You can add the line to your vimrc if you want the behavior to be permanent.

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.