1

When searching for autocompletion on any command via Tab, now vim shows me a list of the available options:

enter image description here

I was used to push the right-arrow -> in order to select an option while navigating them with Tab, but now that doesn't work anymore. I need to push the Space button instead, but that's pretty annoying when going inside a file-system hierarchy as I need to delete every white space again to show the new listing of files.

Is there a way to restore the -> selector?

  • 1
    Do you have set wildmenu in your vimrc? If you don't, adding it should resolve your problem. – statox Feb 7 '18 at 14:53
  • 1
    @statox That's it, thanks! However the wild menu shall be removed to go back to the previous default behaviour: set nowildmenu. If you wish to answer with this, you can proceed – Campa Feb 7 '18 at 15:32
3

The behavior you are describing is controlled by the wildmenu option (:h 'wildmenu')

While the "wildmenu" is active the following keys have special meanings:

<Left> <Right> - select previous/next match (like CTRL-P/CTRL-N)

<Down> - in filename/menu name completion: move into a subdirectory or submenu.

<CR> - in menu completion, when the cursor is just after a dot: move into a submenu.

<Up> - in filename/menu name completion: move up into parent directory or parent menu.

The default value of this option is off but I would say that it is useful to add set wildmenu to your vimrc.

  • 1
    Great, thank you! Ah... then with the wildmenu I can still use the <Down> arrow to select the item.. awesome – Campa Feb 7 '18 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.