2

Since some days ago I stumbled upon an annoying situation every time I tried to edit some files on a server with Vim.

It won't open the files, and a split appeared on each buffer saying:

This security scheme is not implemented
[SSL Cipher ECDHE-RSA-AES256-GCM-SHA384]
I won't open a connection to XXX.XXX.XX.XX (only to XXX.XXX.XX.XX)
ftp: bind: Address already in use

This is quite similar to another annoying thing some dude on Reddit had to deal with. I don't have a Reddit account nor want to make a new one for me, so hopefully he gets to this someday (or maybe someone here can tell him about this).

The weird thing is that, although it would show similar output, I could connect to the server with ftp on the shell. Even didn't had any problems working with files with KDE's Dolphin.

After some hours googling around, I found a workaround for this could be making Vim to use ftp in passive mode (setting let g:netrw_ftp_cmd="ftp -p" on ~/.vimrc - or, you know, /etc/vim/vimrc).

This time it showed the files, still with a split on each buffer. But every time I did some edit and tried to save changes, it throwed another error:

Error detected while processing function netrw#NetWrite:
E16: Invalid range: 14bw!

Vim said it didn't saved any change, but the changes on the server were actually made (!). So this turned out to be annoying as hell.

1

After two days scratching my bald head and googling around trying to find an answer, I realized ftp has something to do with this. So I started messing around with it, trying to get rid of the "This security scheme is not implemented" message. So I realized executing

ftp -z nossl ftp.myserver.com

Would bypass that. Then I just changed the parameter for the ftp call on vim options to

let g:netrw_ftp_cmd="ftp -z nossl"

And voilá. Back to the game, baby. Maybe not a secure thing to do, but... well, it works.

  • 2
    Did you paste the wrong Vim command into your answer? It seems to be identical to the one you discuss as not working in your question. – Rich Jan 26 '18 at 9:41
  • Jesus, you're right. Thanks for pointing it out, @Rich. Best regards :) – acidrums4 Jan 27 '18 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.