0

Currently mark character is bright red as in below screenshot. How to change it?

enter image description here

  • 1
    This is not a default behavior, I guess you are using a plugin to show the mark in the gutter. You should 1) indicate which plugin you use 2) ask your question on the plugin issue tracker. – statox Jan 16 '18 at 17:41
  • 1
    Try following the steps in How do I debug my vimrc file?. – Martin Tournoij Jan 16 '18 at 17:55
1

By default, the vim-signature plugin uses the SignatureMarkText highlighting group for its mark signs.

It's better to set the colour of this in your vimrc rather than editing the plugin's code (which could cause problems if/when you want to update the plugin).

Add the following line to your vimrc file:

highlight SignatureMarkText guifg=White ctermfg=White

(You can also run this command from command-line mode to apply the change without restarting Vim.)

Note that the plugin uses the same mechanism for setting the colour, the CheckAndSetHL() function (for which you altered the parameters in your answer) builds essentially the same command as the above.

1

Mark column is added by plugin: vim-signature.

Need to edit: $HOME/.vim/bundle/vim-signature/autoload/signature/utils.vim

Change 'SignatureMarkText' color.

Need to exit vim to see the change.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.