1

Other than deleting the plugin directory in /bundle/ I have not been able to successfully uninstall a plugin. I found this issue and have tried removing the plugin from my vimrc, running :PluginInstall, :PluginUpdate, and :PluginClean, but I cannot seem to uninstall any of the plugins with vundle. This is my Vim setup. Given my linked vim setup and the commands that I have tried to run, does anyone know what could be wrong? Has anyone ran into this problem before and solved it?

  • I faced the same problem too. Still looking for answer. – Apit John Ismail Jul 25 at 1:21
5
  1. In your _vimrc delete the Plugin 'blabla' line you want to uninstall.
  2. Execute :PluginClean in vim.

By the way, make sure PluginClean do the right thing you should open a new vim window to execute :PluginClean

1

I dont know if this would help. So far it helped me. First I went to .vim/bundle/Vundle.vim

Then I just do "git pull origin master" to pull latest code from the repo. If there is a merge conflict, settle the conflict and pull again. I dont know why, but while you are pulling from the repo, you have to quit any active editting mode on .vimrc

After that, I went back to my .vimrc, do :PluginClean and suddenly all the plugin I cannot delete is deleted properly. Then I do :PluginUpdate to update again.

Hopefully this helps.

My guess is that, vundle did not update its own code correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.