4

I managed to record a macro pressing <leader>-q-r-<letter>, but I can't make it play. The documentations says

SpaceVim has mapped normal q as smart buffer close, the normal func of q can be get by <leader>qr

but says nothing about playing it. I tried <leader>-@-r-<letter> and @-r-<letter> but it didn't work. Could it be because I'm using a German keyboard and the '@' is <AltGr>@-q?

2
  • Does it work without SpaceVim? Dec 18, 2017 at 6:53
  • Yes, it does work.
    – skmecs
    Dec 18, 2017 at 12:44

1 Answer 1

8

SpaceVim uses leaderqr instead of q because it remaps q to another function.

As far as I can tell from the documentation, @ is not used for another function: so you play back macros in the usual way: @letter

1
  • I can't reproduce the problem anymore. And I'm not 100% sure if that did the trick, but one thing I tried was changing the layout language to English and back to German.
    – skmecs
    Dec 18, 2017 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.