1

I have read this article & I added se gcr+=a:blinkon0 in my vimrc to stop blinking cursor in my Vim, also I sourced my vimrc again but the matter is it doesn't work & cursor is still blinking in all modes. Please let me know why it doesn't work for me & How can I fix it?

Edit 1:

OS: Fedora Linux 27 x86_64 & Vim version: 8.0

Edit 2: I think I have found a solution for that. Actually Herb Wolfe was right and this option seems not working on Vim (but in gvim it works fine). For stop cursor blinking you can disable cursor blinking in your terminal emulator instead. Also this wiki may help.

  • 2
    Which operating system are you using, and are you using vim or gvim? The article states that the OS has to support it, and that particular option appears to only apply to gvim. – Herb Wolfe Dec 14 '17 at 19:51
  • Question edited. I didn't see that article refer to OS supporting for that feature so this feature can't work on VIm? – Cy8099 Dec 14 '17 at 20:22
2

In gvim you use:

set guicursor+=a:blinkon0

In vim run in the terminal you would change the terminal setting to disable the blinking.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.