4

I'm using Neovim 0.2.2 on macOS High Sierra (10.13.1), installed via brew install neovim.

I removed .config/nvim/init.vim.

Neovim starts up using German for interface labels, as shown here:

German labels in Neovim interface

Here's the output of locale:

LANG=
LC_COLLATE="C"
LC_CTYPE="en_US.UTF-8"
LC_MESSAGES="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_ALL=

Here are my "Language & Region" settings:

macOS Language & Region Settings

All my other applications, GUI or command line, are in English.

Can someone enlighten me on what is causing Neovim to display German interface labels and how I can override that to use English instead?

I searched the Neovim documentation and Google on how to manually set Neovim's interface language, but couldn't find anything.

  • 1
    Is this not relevant? github.com/neovim/neovim/issues/5873 – Mass Dec 5 '17 at 16:38
  • 2
    It is! I think I had skimmed that issue but disqualified it at being about something different too hastily... But in the last comment someone actually provides a nice solution that doesn't mess with the environment: putting language en_US in .config/nvim/init.vim. Thanks! If you want to post it as an answer I'd accept it. – anothernode Dec 5 '17 at 17:12
2

Regarding the second part of my question: just after posting I had the ingenious idea of setting LANG=en_US and that actually works.

Just out of curiosity, I'd still be interested in the answer to the first part: where exactly did Neovim get the idea to use German instead of defaulting to English in the first place?

2

Here is what you should do:

  1. Open ~/.config/nvim/init.vim (or create it if not present)
  2. Add a line language en_US
  3. Save it and reload Neovim

I would like to give all the credits to @anothernode. I've just convert his comment into the regular answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.