1

Sometimes I'm using GVim not only for coding, but also for typing texts in Russian language.

I'm very annoyed that I have to switch my keyboard layout back to English each time when I return to command mode. Is there any way to make GVim obeying keycodes sent by X server rather than keysyms, so that it could work in command mode regardless to which keyboard layout is selected?

1

One option is to use the plugins https://github.com/lyokha/vim-xkbswitch or https://github.com/rlue/vim-barbaric, which switch the input method in vim's input mode using xkbswitch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.