1

MacOS Sierra 10.12.6 + iTerm2, build 3.1.4 + NeoVim 0.2.0_1.
I run on iTerm a Tmux session loaded with

teamocil [session]

In one of tmux windows there's an instance of nvim working smoothly, everything is displayed in its own place in all of the bottom three lines, from last one: tmux status bar, nvim command line, nvim status line. Here's the relevant shot:

Everything in place

In another tmux window I want to use a nvim session, sourced with

nvim -S [path to session.vim]

But here, in this nvim restored session, Tmux does not allow nvim to display messages in its command line, leaving no free lines between Tmux and nvim status lines. Whatever message displayed ovelaps status line, getting an unreadable mess. See following shot:

nvim session mess

It looks like nvim is not getting the correct terminal size when it starts session, either it is not reading it correctly or it is missing the WINCH signal. Sending a

kill -WINCH $PID

signal from another shell solves the problem, so I adopted this as a temporary workaround, sending above command as a slightly delayed background process when opening tmux session. But I think this is a neovim related issue and has to be fixed.

Just to make it clear the problem appears only sourcing an existing nvim session inside Tmux. Thank you.

closed as off-topic by 8bittree, statox Nov 10 '17 at 10:20

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question was caused by a problem that can no longer be reproduced or a simple typographical error. While similar questions may be on-topic here, this one was resolved in a manner unlikely to help future readers." – 8bittree, statox
If this question can be reworded to fit the rules in the help center, please edit the question.

  • The problem spontaneously solved updating some homebrew formulae and/or restarting for the n.th time iTerm2. This may be closed. Thank you. – Daniele Nov 9 '17 at 14:28

Browse other questions tagged or ask your own question.