1

I've noticed that recently when I quit vim it prints the following text to the terminal:

--- Options ---
  background=dark  helplang=en  relativenumber
  cursorline  number  scroll=11
  runtimepath=~/.config/nvim,~/.config/nvim/plugged/vim-sensible/,~/.config/nvim/plugged/vim-multiple-cursors/,~/.config/nvim/plugged/molokai/,~/.config/nvim/plugged/vim-colors-solarized/,~/.config/nvim/plugged/vim-commentary/,~/.config/nvim/plugged/lucario/,~/.config/nvim/plugged/vim-auto-save/,~/.config/nvim/plugged/vim-cpp-enhanced-highlight/,~/.config/nvim/plugged/Improved-Syntax-Highlighting-Vim/,~/.config/nvim/plugged/vimtex/,~/.config/nvim/plugged/vim-sneak/,~/.config/nvim/plugged/pretty-vim-python/,~/.config/nvim/plugged/supertab/,~/.config/nvim/plugged/simpylfold/,~/.config/nvim/plugged/vim-fish/,~/.config/nvim/plugged/vim-airline/,/etc/xdg/nvim,~/.local/share/nvim/site,/usr/local/share/nvim/site,/usr/share/nvim/site,/usr/local/Cellar/neovim/0.2.0_1/share/nvim/runtime,/usr/share/nvim/site/after,/usr/local/share/nvim/site/after,~/.local/share/nvim/site/after,/etc/xdg/nvim/after,~/.config/nvim/plugged/vim-cpp-enhanced-highlight/after,~/.config/nvim/plugged/vimtex/after,~/.config/nvim/after

I'm on a mac and I use neovim but the same behavior happens in regular vim. I don't think I changed anything recently but here is my vimrc file:

call plug#begin()
Plug 'tpope/vim-sensible'
" Plug 'scrooloose/nerdcommenter'
Plug 'terryma/vim-multiple-cursors'
Plug 'tomasr/molokai'
Plug 'altercation/vim-colors-solarized'
Plug 'tpope/vim-commentary'

"Plug 'severin-lemaignan/vim-minimap'
Plug 'raphamorim/lucario'
Plug '907th/vim-auto-save'
"
Plug 'octol/vim-cpp-enhanced-highlight'
Plug 'dragfire/Improved-Syntax-Highlighting-Vim'
Plug 'lervag/vimtex'
"Plug 'klen/python-mode'
"Plug 'hdima/python-syntax'
"Plug 'dragfire/improved-syntax-highlighting-vim'
"Plug 'sheerun/vim-polyglot'
" Plug 'easymotion/vim-easymotion'
" Plug 'goldfeld/vim-seek'
Plug 'justinmk/vim-sneak'
"Plug 'vim-scripts/TagHighlight'
"Plug 'xolox/vim-easytags'
"Plug 'xolox/vim-misc'
Plug 'sentientmachine/pretty-vim-python'
Plug 'ervandew/supertab'
Plug 'tmhedberg/simpylfold'

Plug 'dag/vim-fish'
Plug 'bling/vim-airline'
" Plug 'vim-airline/vim-airline-themes'
call plug#end()


colo molokai

"let python_highlight_builtins = 1
"let g:pymode_python = 'python3'
if has("gui_vimr")
 let g:molokai_original = 1
endif

inoremap jk <Esc>

set number
set relativenumber
set cursorline
set 
syntax on

let g:multi_cursor_exit_from_insert_mode = 0
let g:multi_cursor_insert_maps = {'j':1}


"set nofoldenable
set foldlevel=99
set clipboard=unnamed
nnoremap <esc> :noh<return><esc>

set spell
set mouse=a

let g:vimtex_view_method = 'skim'
let g:vimtex_view_general_viewer
      \ = '/Applications/Skim.app/Contents/SharedSupport/displayline'
let g:vimtex_view_general_options = '-r @line @pdf @tex'

I don't see any option that could be causing it but I've tried disabling plugins randomly but couldn't come up with a thing which removes the printing

  • Instead of disabling the plugins randomly try to follow the guidelines in this question (especially confirming that the problem comes from your vimrc with vim -U NONE and edit your question with what you found while debugging your .vimrc it will make it easier for the others to help you. – statox Oct 16 '17 at 11:14
5

From your .vimrc:

...
set cursorline
set                " <- HERE
syntax on
...

This set command must be causing it.

Looks like during initialization Vim dumps output to terminal, but you don't see it until Vim is closed. I get similar behaviour if I put stray set to my .vimrc file (although I do need to press enter to skip the output, but this must be due to much bigger number of changed options).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.