0

This's kind of odd question but I can't change the runtimepath of gvim to comply the same manner like under linux (plugins put under .vim)

I tried to append .vim at the begin of runtimepath like: set runtimepath^=~/.vim/,$VIMRUNTIME, it doesn't work.

The workaround solution is use mklink command of windows to make .vim as a softlink of vimfiles folder mklink /D .vim vimfiles, but really don't expect this.

So is there a way to make vim to look into .vim folder instead of vimfiles on windows 10?

P/S: I'm trying to use packages to manage plugins.

  • why do you need this? – Christian Brabandt Oct 12 '17 at 6:14
  • Why don't I need it? – Tuyen Pham Oct 12 '17 at 6:16
  • because there must be a reason, why you want to change your vimruntime setting? Seriously, Vim works without changing your runtimepath, so what is the reason you want to change it? – Christian Brabandt Oct 12 '17 at 7:04
  • Change runtimepath is nothing special and is an option to users. That's open-source way imo. Windows support . files so there's no reason why it doesn't work. – Tuyen Pham Oct 12 '17 at 7:07
  • If youre just trying to manage plugins try vim-plug. Really great and easy to use and it manages all your plugings amazingly – ljden Oct 12 '17 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.