0

This question already has an answer here:

I just installed kotlin-vim plugin. The plugin looks like using 8-spaces indentation.

How can I change it 4-spaces indentation?

(To indent all codes I used gg=G. Maybe I'm using wrong way for indent all the text.)

marked as duplicate by Martin Tournoij Mar 8 '18 at 6:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    What are your tab settings in your .vimrc? – Herb Wolfe Oct 8 '17 at 14:52
  • I see, it's just depends on default tab setting. Thanks. – ironsand Oct 8 '17 at 14:59
0

After the plugin calls in your .vimrc have a selection of the following (depending on desired configuration):

set tabstop=4     // how tabs are displayed
set shiftwidth=4  // how far a shift moves a line
set softtabstop=4 // how many spaces are inserted by pressing tab*
set expandtab     // insert tabs as spaces

* if you are inserting tabs after text it will insert up to softtabstop spaces until the number of characters on the line is a multiple of softtabstop

Not the answer you're looking for? Browse other questions tagged or ask your own question.