1

I used to have a similar problem with the main screen (IIRC), like here:

vim-lines-bg-problem

and I solved it by setting set set t_ut=, as was suggested in this question's accepted answer. But now I spotted another similar problem:

vim-bg-shell-output-problem

and I have not been able to fix it, following directions from other similar questions: Vim Colorscheme Weirdness for Background, 256 color support for vim background in tmux, namely setting the TERM variable's value to screen or screen-256color. I tried, but to no avail:

foo@bar$ TERM=screen
foo@bar$ echo $TERM
screen
foo@bar$ vim /etc/apache2/ports.conf

I use Terminator as a terminal, but, it seems, this doesn't matter, since in the default Ubuntu terminal the problem is the same.

It's not that this is a huge problem, but it's still annoying.

Could anyone help? Thank you in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.