0

I have downloaded vim-latex-1.9.0.tar.gz. Then I follow the instruction describe here. But, the plugin doesn't run.

My .vimrc looks like -

set showmatch
inoremap { {}<Left>
inoremap {<CR> {<CR>}<Esc>O
inoremap ( ()<Left>
inoremap [ []<Left>
inoremap < <><Left>
"inoremap "\begin{document}" "\begin{document}<CR>\end{document}<Esc>O"





" REQUIRED. This makes vim invoke Latex-Suite when you open a tex file.
filetype plugin on

" IMPORTANT: win32 users will need to have 'shellslash' set so that latex
" can be called correctly.
set shellslash

" IMPORTANT: grep will sometimes skip displaying the file name if you
" search in a singe file. This will confuse Latex-Suite. Set your grep
" program to always generate a file-name.
set grepprg=grep\ -nH\ $*

" OPTIONAL: This enables automatic indentation as you type.
filetype indent on

" OPTIONAL: Starting with Vim 7, the filetype of empty .tex files defaults to
" 'plaintex' instead of 'tex', which results in vim-latex not being loaded.
" The following changes the default filetype back to 'tex':
let g:tex_flavor='latex'

and /.vim/ftplugin/tex.vim looks like-

" this is mostly a matter of taste. but LaTeX looks good with just a bit
" of indentation.
set sw=2
" TIP: if you write your \label's as \label{fig:something}, then if you
" type in \ref{fig: and press <C-n> you will automatically cycle through
" all the figure labels. Very useful!
set iskeyword+=:
2

All you have to do to install vim-latex manually is download the tarball and extract it in your vimfiles or .vim directory. The .vimrc and the tex.vim files will change some latex settings, but do not effect installation.

vim-latex recommends using a plugin manager like pathogen or Vundle to install vim-latex. You can install pathogen and then enter

cd ~/.vim/bundle && \
git clone https://github.com/vim-latex/vim-latex

Note: you will have to make appropriate changes if you work on Windows. The ~/.vim directory ~\vimfiles

PS: your vim.tex file should be a tex.vim file. This won't effect installation, but you won't get your indentation and caption preferences until you fix this.

  • I wrote vim.tex instead of tex.vim I changed my ques. – alhelal Oct 2 '17 at 0:33
  • :help latex-suite.txt shows E149: Sorry, no help for latex-suite.txt I have downloaded latex-suite.txt and put under ~/.vim/doc/ – alhelal Oct 2 '17 at 4:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.