1

It's only happening in one of my .py files when opened with vim, I am getting some kind of fold info in the gutter that shouldn't be there - made up of the characters '2', '-' and '|'.

enter image description here

I disabled all my plugins to test if there is some plugin issue, but the problem remains. I deleted the files pertaining to this .py in the views folder in case that may be the issue, but to no avail.

The foldmethod is set to indent. If I change the foldmethod to marker then that annoying info in the gutter goes away, but comes back once I reselect indent method.

The folds look normal when folded however:

enter image description here

Anyone know what is happening, or how to get rid of it?

4

What you see is the 'foldcolumn' setting for opened folds. If you don't want it, simply disable it: :set foldcolumn=0 To find out where it was set, enter :verbose set foldcolumn? You might also play with increasing the foldcolumn value, so that the display looks a little bit better.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.