0

When running gvim on my RedHat:

Linux trex-06 3.10.0-514.el7.x86_64 #1 SMP Wed Oct 19 11:24:13 EDT 2016 x86_64 x86_64 x86_64 GNU/Linux
NAME="Red Hat Enterprise Linux Server"
VERSION="7.3 (Maipo)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="7.3"
PRETTY_NAME="Red Hat Enterprise Linux Server 7.3 (Maipo)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.3:GA:server"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.3
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.3"
Red Hat Enterprise Linux Server release 7.3 (Maipo)
Red Hat Enterprise Linux Server release 7.3 (Maipo)

The spacing between letters is too wide which looks really bad.

enter image description here

I tried changing font (:set guifont=*) to monospace, and it stays exactly the same. Same goes for other fonts.

Any idea how to fix it?

  • Probably the same as this? If you set an invalid guifont Vim will default to that ugly font. What did you set guifont to exactly? set guifont=Dejavu\ Sans\ Mono\ 12 should work on most Linux systems (if not, try Bitstream\ Vera\ Sans\ Mono\ 12). – Martin Tournoij Aug 31 '17 at 14:00
  • @Carpetsmoker tried that of course. Only changes the font size. Also tried to select manually with set guifont=*. Perhaps no fonts installed at all? – Elad Weiss Aug 31 '17 at 14:22
1

As it turns out the fonts that

:set guifont=*
show are not installed.

No idea why gvim decides to show them. Might be a bug.

Also the suggestion here doesn't work. I believe that the font suggested is also not installed.

So a friend found:

:set guifont=Courier\ 10\ Pitch\ 13

Which works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.