1

I usually use vim inside screen over ssh and sometimes I notice problems with the entire line "shifting over" when inserting text in a vertical split.

Any one of these programs could be responsible for messing up redisplay, but when it does happen, it's distracting.

Is there a way to completely disable vertical splits in vim (even via C-w L or things that open automatic splits or quickfix buffers) and make vim behave as if it weren't compiled with support for them.

  • 1
    Why not just don't use splits instead of trying to make it impossible to open a split? – James Aug 28 '17 at 22:23
  • because it seems like the kind of thing that might be hidden away in some config setting somewhere. And I do want to horizontal/<c-w>s splits still. It's also possible that someone has encountered the pathological shifting behavior and a found another way to solve it. – Gregory Nisbet Aug 28 '17 at 22:26
5

The feature which controls whether vim supports vertical splits is called +vertsplit and it is not possible to disable it alone at compile time. Specifically, since patch 7.4.1611, vim always supports vertical splits when feature +windows is enabled (FEAT_WINDOWS). The FEAT_VERTSPLIT preprocessor definition has been completely removed.

Incidentally, :help feature-list claims that +vertsplit is enabled only in the "normal" build and up, but this is wrong since +windows is enabled in the "small" build.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.