0

I'm having a weird problem lately when I'm coming out of Insert Mode to navigate in Normal Mode after just one navigation command (w,b, etc) vim sets me into Insert Mode Again, I'm not using the Insert Normal Mode.

For example: I want to navigate my text so I know I could press Esc w Or Esc b but if I would like to keep on going more than one word I would like to Esc b b b and navigate three words backwards but instead I end up navigating one word backwards and insert two b characters in the text.

This has been driving me crazy but can't find an answer to it. Anyone has any knowledge of why would this happen.

It seems as if I wait for a little before pressing the b (or w or any navigation key) then I'm not put back on Insert mode, so there might be a setting on that enables this behaviour.

Any help is appreciated.

  • 2
    Start vim without any customizations using vim -u NONE -U NONE and try again. If this helps, then check vi.stackexchange.com/questions/2003/… – Vitor Jul 11 '17 at 17:14
  • Thanks Vitor, exactly what I needed to debug, It appears to be some of my plugins. Thanks for your help. – Derik Ramirez Jul 12 '17 at 8:17
  • Perfect it was my vimrc: Here was the culprit: silent! exe "set <S-Left>=\<Esc>b" silent! exe "set <S-Right>=\<Esc>f" Not sure why that affected the regular keybind, but once removed it started working as expected. Thanks Vitor – Derik Ramirez Jul 12 '17 at 8:34

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.