0

My vim-airline plugin looks like this: enter image description here

But on all screenshots it might be like this: enter image description here

Here my Vundle plugins list:

Plugin 'VundleVim/Vundle.vim'
Plugin 'ctrlpvim/ctrlp.vim'
Plugin 'scrooloose/nerdtree'
Plugin 'rking/ag.vim'
Plugin 'skwp/greplace.vim'
Plugin 'MarcWeber/vim-addon-mw-utils'
Plugin 'tomtom/tlib_vim'
Plugin 'garbas/vim-snipmate'
Plugin 'tpope/vim-surround'
Plugin 'StanAngeloff/php.vim'
Plugin 'arnaud-lb/vim-php-namespace'
Plugin 'ervandew/supertab'
Plugin 'stephpy/vim-php-cs-fixer'
Plugin 'tobyS/vmustache'
Plugin 'tobyS/pdv'
Plugin 'SirVer/ultisnips'
Plugin 'vim-airline/vim-airline'
Plugin 'vim-airline/vim-airline-themes'

Some config from my .vimrc file, without plugins config:

set nocompatible

syntax enable
set backspace=indent,eol,start
set number
let mapleader = ',' 
set noerrorbells visualbell t_vb=           
set autowriteall                    
set complete=.,w,b,u                    
set tabstop=8
set expandtab
set softtabstop=4
set shiftwidth=4

"------------Visuals-------------"
set background=dark
colorscheme material-theme
set t_CO=256                
set guifont=Operator\Mono\ weight=350\ 10
set linespace=10
set guioptions-=e           

set guioptions-=l           
set guioptions-=L
set guioptions-=r
set guioptions-=R

hi LineNr guibg=bg
set foldcolumn=2
hi foldcolumn guibg=bg

hi vertsplit guifg=bg guibg=bg

I using Ubuntu 16.04, try to use gVim and terminal vim, the same.

I try to comment all visual config like theme, guifonr, but the same result.

  • the default changed recently. Also if you want those nice little triangles, you need to configure airline to use those poweline glyphs. Read the documentation on how to do it. – Christian Brabandt Jun 15 '17 at 8:35
2
  1. install fonts with powerline symbol.YaHei-Consolas-Hybrid-For-Powerline
  2. set your terminal's font to this font.
  3. set guifont and guifontwide to this font in the case gvim & macvim.see this
  4. set airline symbol.

https://github.com/tracyone/t-vim/blob/master/rc/airline.vim

1

I installed powerline/fonts and after the commands:

# clone
git clone https://github.com/powerline/fonts.git
# install
cd fonts
./install.sh
# clean-up a bit
cd ..
rm -rf fonts

My status looks like better, but not ideal, I think it's because I didn't find my font in that repository, but it`s nit big problem.

Now my panel look like this: sample

  • 1
    That's because of your linespace setting. Setting this option to 10 will result in 5 additional rows of pixels both above and below every line, including your status line. This additional rows inherit their background color from the original line. – Jürgen Krämer Aug 15 '17 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.