1

I am searching a Plugin for autocompletion which does not have any requirements to lua ruby or python. I would love to use YouCompleteMe but it requires python, which is not availiable on my server.

At all vim there does not have lua, python or ruby support, which makes it really hard to find anything.

Maybe there is something written in Go like for example fzf, which could be easily added to vim without sudo permission.

2

Try vim-µcomplete https://github.com/lifepillar/vim-mucomplete. It is a minimalistic autocompletion plugin, written in VimL.

2

Asyncomplete is a fork of Neovim Completion Manager that works on Vim 8 and removed the Python dependency.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.