2

I manually installed the Solarized colour scheme from the Vim-only repository and adjusted my ~/.vimrc as indicated in the documentation, including using set background=dark.

GVim 7.4 (GTK3) under Kubuntu 16.04 correctly displays the dark solarized theme. However, changing the configuration to set background=light as detailed in the documentation results in the same dark color scheme after calling colourscheme solarized again or after restarting Vim with the new configuation. How do I use the light theme in GVim?

PS: I installed G/Vim (GTK3) 8.0 from the git source. It, too, does not display the light theme.

0

This is what works for me (GVim 7.4, Ubuntu 16.04.2):

~/.vimrc

set background=dark
set t_Co=16              " fix for bg being too bright
colorscheme solarized

" gvim specific settings here                       
if has('gui_running')
    set background=light
    set guioptions-=T    " no toolbar
    set linespace=5      " to show underscores not as space
endif
  • Have you tested that? I would have thought (another) colorscheme would be required after setting the light background? Either way, this is unrelated to my question, as I have followed the instructions for the light theme, but it does not appear. – SabreWolfy Mar 25 '17 at 18:18
  • 2
    I copied these settings directly from my vimrc. So yes it's tested and works (at least on my system). – jhscheer Mar 25 '17 at 18:27
  • @SabreWolfy: You don't generally need to call :colorscheme after setting the background. As :help 'background' states: "When a color scheme is loaded (the "g:colors_name" variable is set) setting 'background' will cause the color scheme to be reloaded. If the color scheme adjusts to the value of 'background' this will work." – Rich Jul 24 '17 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.